Tuesday, October 23, 2012

GnuPlot installation in Ubuntu 12.04

We need to make sure some packages are already installed before we try to compile gnuplot

  1. sudo apt-get install libwxgtk2.8-dev libpango1.0-dev libreadline5-dev libx11-dev libxt-dev texinfo libgd2-xpm-dev
  2. wget http://sourceforge.net/projects/gnuplot/files/gnuplot/4.4.0/gnuplot-4.4.0.tar.gz/download
  3. tar xzf gnuplot-4.4.0.tar.gz
  4. cd  gnuplot-4.4.0
  5. ./configure
  6. sudo make install 

Saturday, October 20, 2012

Installing NS-2.31 in Ubuntu 12.04

Follow the below given steps:

  • Download ns-allinnone-2.31 from nasam website
  • Create a folder in /home with the name ns2
  •  Extract the tar file in ns2 
  • Open terminal and type cd ns2/ns-allinone-2.31
  •  Install required libraries for ns2 using terminal
            sudo apt-get install build-essential autoconf automake libxmu-dev
  •  Then, sudo ./install 
 For errors,


ld: libotcl.so: hidden symbol `__stack_chk_fail_local' isn't defined
ld: final link failed: Bad value
make: *** [libotcl.so] Error 1
otcl-1.13 make failed! Exiting ...
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems

In otcl-1.13/configure, line number 5516

-SHLIB_LD="ld -shared"
+SHLIB_LD="gcc -shared"